There is windows server 2012 r2.I created a policy for the computer so that when the user logs in to his desktop, the RDP shortcut is copied.
In the rights to GPO set: Specifically, so far only your PC(read-execute), Domain computers(read).
Must copy from balls where"SYSTEM" has full rights.Copy must in% HOMEPATH% \ Desktop \ MicrosoftOffice_RND.rdp
Tied a policy to OU with a computer.
After gpupdate/force errors fall out: 0x80070003 or 0x80070005.
I understand the problem of rights to the ball, but I don’t understand how to solve it correctly
  • why do you need to directly copy? in gpo in the very creation of a shortcut anywhere.
    users configuration - preference- windows setting - Shortcuts
    this is the first.

    and the second.
    you don’t need to go into the rights of civil defense. you attach GPO to OU where the computer or user account lies(envy of the one you use GPO for)
    copy from any balls where everyone has read access, and domain users are safe to read.
    throw a shortcut there

    and what do you copy at all? a script? or what?
    – Fruity53 Oct 15 '19 at 13:32
  • I’m copying using Group Policy Preferences.You’re right, you can also use a shortcut, but I wanted to try copying. – Brainy100 Oct 15 '19 at 14:15

1 Answers 1

And in the GPO itself, too, the settings are made in the section for the computer? Maybe you have some tricky script there, but logically(a shortcut is needed for the user) you need to do this for users and apply the policy on OU with users, IMHO.
In general, it will probably be easier to use Group Policy Preferences in this case.

  • Not any scripts.

    Everything is simple
    – Brainy100 Oct 15 '19 at 13:49
  • Users will often change, but computers will not.It’s easier for me to do politics on a PC – Brainy100 Oct 15 '19 at 13:51
  • I can of course be mistaken(I haven’t climbed GPO for a long time), but it seems that at the stage of processing policies for a computer such a variable as% HOMEPATH% will still not be known, because it refers to the user.
    Users will often change, but no computers.It will be easier for me on a PC
    do politics

    So you apply the policy not to a specific user(computer), but to OU with users(computers).
    – Vast Vole Oct 15 '19 at 13:56
  • Alternatively, you can add a shortcut to AllUsers(or Default, depending on the system). – Vast Vole Oct 15 '19 at 13:58
  • Thank you.You turned out to be right, I changed it to Default/Desktop and everything worked.It seems that the% HOMEPATH% variable really needs to be used for user policies. – Brainy100 Oct 15 '19 at 14:33